Re: [Excel] Come confrontare colonne in Excel e verificare valori

Messaggioda bad.alex » 01/12/2019, 21:30

Grazie per la tua risposta, axpgn.
Quindi, se ho capito bene, ho:
- una tabella del tipo

AA BB CC
IDS GRUPPO SCORE


-e un'altra con

A B C D
Old New Old Score New Score



dove Old Score e New Score sono da determinare con CERCA.VERT, ovvero:

- Per Old Score uso CERCA.VERT(A2, AA2, C2)
- Per New Score uso CERCA.VERT(B2, BB2, D2)

Ho un dubbio a riguardo: come faccio in questo caso ad associare ids, gruppo e score a old id e a new id?
Sarebbe possibile così estendere questa funzione a tutti gli elementi presenti in old e new (cliccando quel + quando si seleziona la cella)?
bad.alex
Senior Member
Senior Member
 
Messaggio: 1138 di 1140
Iscritto il: 10/01/2007, 19:01

Re: [Excel] Come confrontare colonne in Excel e verificare valori

Messaggioda axpgn » 01/12/2019, 21:52

Non sono sicuro se ci siamo capiti :D … allora ecco un esempio …

Testo nascosto, fai click qui per vederlo
Immagine


La formula della prima riga OLD SCORE è =CERCA.VERT(B5;\$I\$4:\$J\$11;2)

La formula della prima riga NEW SCORE è =CERCA.VERT(C5;\$I\$4:\$J\$11;2)
axpgn
Cannot live without
Cannot live without
 
Messaggio: 14556 di 15292
Iscritto il: 20/11/2013, 22:03

Re: [Excel] Come confrontare colonne in Excel e verificare valori

Messaggioda bad.alex » 01/12/2019, 22:19

Ti ringrazio axpgn. ll 2 finale nella formula deve essere preceduto da una lettera oppure è corretto scritto così ? Non conoscevo decisamente questa funzione e l'unica cosa che mi era venuta in mente è stata quella di utilizzare condizioni if e combinazioni di ids.
bad.alex
Senior Member
Senior Member
 
Messaggio: 1139 di 1140
Iscritto il: 10/01/2007, 19:01

Re: [Excel] Come confrontare colonne in Excel e verificare valori

Messaggioda axpgn » 01/12/2019, 22:26

No, è il numero d'ordine della colonna nella tabellina ... la tabellina deve contenere nella prima colonna il valore da cercare mentre nella altre (la seconda, la terza, ecc.) i valori da restituire; in questo caso il valore da restituire è nella seconda colonna quindi si mette $2$ (vabbè non ce n'erano altre :D )
axpgn
Cannot live without
Cannot live without
 
Messaggio: 14557 di 15292
Iscritto il: 20/11/2013, 22:03

Re: [Excel] Come confrontare colonne in Excel e verificare valori

Messaggioda bad.alex » 02/12/2019, 00:50

Grazie mille. Adesso è decisamente più chiaro :wink:
bad.alex
Senior Member
Senior Member
 
Messaggio: 1140 di 1140
Iscritto il: 10/01/2007, 19:01

Precedente

Torna a Informatica

Chi c’è in linea

Visitano il forum: Google [Bot], Raptorista e 9 ospiti